Motherload Mine
#1
Motherload Mine - BETA


   
Script Features:
- Mines 3 trips of ore before searching sack
- Anti-stuck failsafes
- Ability to handle fallen rockfalls
- Drops all uncut gems
- Hops worlds if both wheels are broken
- Always knows where the player is located based on current position


* Script may be found on the Script Repository
OSRS Script Factory
  Reply
The following 3 users Like Project's post:
  • A G, ImViolent, seppe
#2
https://i.tws.gg/pQPatpKH2Y.png
  Reply
The following 1 user Likes lukeeexd's post:
  • Project
#3
worked for about 5 hours with mostly no problems. recently ive noticed it getting stuck between the two rockfalls on the way to deposit ore in the hopper(never on the way back). I'd say its happened 4 times in 6 hours but will stand there indefinitely( i think, i always fix it asap when i notice) which is obviously big problem. meant to take note of the line that is being displayed. I think its something like " Am I being obstructed on my way to the hopper? (false)" it will change to true once the rockfall eventually lands back in front of the character and will mine it, then go back to the old line. tried moving the camera around to see if that helped and it didn't(although might play a role in how it ends up stuck to begin with).

more minor things are it will sometimes click on ores that are on the other side of walls or whatever and ends up running around. like sometimes it will clear a path through the rockfall to go somewhere then click on an ore that sends it in some opposite direction.

It happened again as i was writing this and Is rendering it unusable. thats 3 times in half an hour. the line being displayed is < boolean> set boolean to-(to_hopper, false)

im using mirror mode and have "new mouse" selected. not sure why its getting stuck way more frequently now rather than before, maybe its a busier time of day and other players are the culprit.

Thank you for everything and hope this helped
  Reply
#4
getting stuck at the hopper now after depositing pay-dirt. says its trying to get back to the ore but wont move unless i inch it manually closer to the rockfall. thought it had to do with sometimes failing to fix the strut (it can take a while sometimes) but the issue persisted after i added a sleep for after clicking on the strut to fix it.

Maybe it has to do with odd numbers of pay-dirt in the sack due to hammer now often being in inventory (thus 27 are deposited instead of 28).
^ that doesnt seem to be the case

what its displaying while standing at hopper indefinitely:
State: depositing pay-dirt in hopper
Running (30): <boolean> set boolean to-[to_ores,true]

wont fix itself until im like 6-7 tiles from the rockfall leading out

this is happening much more often than the last issue.


anyway hope this helps and thanks again
  Reply
#5
Yea I have made a lot of fixes, just forgot to push before I left. Lol
OSRS Script Factory
  Reply
#6
Made a new push. v0.10 is now live!
OSRS Script Factory
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)